XML in InDesign
Teaching Plan (5 Hours)

Compiled by
Biotics Faculties
XML in InDesign CS2

Overview

7.1 XML Structure
7.1 Import XML tags
7.2 Apply XML tags
7.3 Mapping tags and styles
7.4 Use the Structure pane
7.5 Import XML
7.6 Export XML
7.7 Troubleshooting
Overview

First of all remember that to use the XML features of InDesign CS2, you do not need extensive XML knowledge. So first of all we will learn the entire XML Structure.

XML Structure

XML Document

A data object that is well-formed, according to the XML recommendation, and that might (or might not) be valid. The XML document has a logical structure (composed of declarations, elements, comments, character references, and processing instructions) and a physical structure (composed of entities, starting with the root, or document entity).
XML Version Declarations

कोई या version use किया जा सकता है। जिसमें वह परा परा है कि अनुक्रम document XML coded किया हुआ है।

It is the information for the application. XML documents start with an XML version declaration (XML declaration) which specifies the version of XML being used.

It is suggested by the W3C specification. The XML declaration is a processing instruction that notifies the processing agent that the following document has been marked up as an XML document. It will look something like the following:

```xml
<?xml version="1.0"?>
```

The version declaration can also contain other information such as an encoding declaration or standalone declarations.

Encoding Declarations

Encoding Declarations inform the processor what kind of code the document uses (e.g. UTF8, which is the same character set as ASCII). All XML parsers must support 8-bit and 16-bit Unicode encoding corresponding to ASCII. However, XML parsers may support a larger set. For a list of encoding types go to the XML Specification.

```xml
<?xml version="1.0" encoding="UTF-8"?>
```

dtd (Document Type Definition)

इसमें file में use करने करने tags well formed and systematically define किये होते हैं। अगर XML file में कोई ऐसा tag use किया जाता है जो dtd में define नहीं है तो XML verify/parse नहीं हो पाती है।

dtd in XML is a grammar that describes what tags and attributes are valid in an XML document that refers to the DTD, and in what context the tags and attributes are valid.

In other words it is the markup declarations that describe a grammar for a class of documents. The DTD is declared within the document type declaration production of the XML file. The markup declarations can be in an external subset (a special kind of external entity), in an internal subset directly within the XML file, or both. The DTD for a document consists of both subsets taken together.

XML dtd Declaration

dtd file का नाम निम्न जाता है या वाले उस file को call किया जाता है।

```xml
<!DOCTYPE book SYSTEM “docdtd.dtd”>
```

XSL (Extensible Stylesheet Language)

जिस प्रकार रम कोई style sheet करते हैं और according to the job उसकी configuration set करते हैं उसी तरह XSL XML coding document का style set करता है। यानी दूसरे यहाँ में XSL XML की style sheet है। “XSL is a way of applying transformations and formatting to XML documents.”
XSL Declaration

XML coding document में अपने कार्य के लिए XML document के लिए XSL file को call/read करने हेतु।

food.xsl

```xml
<?xml version="1.0" encoding="UTF-8"?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform" xmlns:fo="http://www.w3.org/1999/XSL/Format">
  <xsl:template match="/">
    <xsl:apply-templates/>
  </xsl:template>
  <xsl:template match="*">
    <xsl:apply-templates/>
  </xsl:template>
  <html>
    <body style="margin: 3% 17% 3% 17%; font:normal 1em Myriad Roman;">
      <xsl:apply-templates/>
    </body>
  </html>
</xsl:stylesheet>
```

XML Entity

The function of an XML entity is similar to that of a macro definition.

Entity in XML is a virtual storage unit. It is often a separate file, but may be a string or even a database record. In XML, an entity declaration provides the ability to have constants or replacement strings, which are expanded by a pre-processor.

An entity declaration maps some token to a replacement string. Later the token can be prefixed with the & character and the replacement string is put in its place.

There are three things that might loosely be called entities in XML:

1. Internal entities function as typing shortcuts or macros.
2. External entities allow you to incorporate content from other files.
3. Parameter entities, which can be internal or external, are only available within the internal and external subsets (the DTD).

An XML parser reading this document will look for an external entity e.g. named “isoamsn.ent” and report an error if it doesn’t find it. If it does find a file named that looks like this,

<table>
<thead>
<tr>
<th>Code for Entity</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&amp;amp;#8809;</code></td>
<td>&lt;!-U02269 /gneq N: greater, not equals --&gt;</td>
</tr>
<tr>
<td><code>&amp;amp;#8809;</code></td>
<td>&lt;!-U02269 /gneqq N: greater, not dbl equals --&gt;</td>
</tr>
<tr>
<td><code>&amp;amp;#8935;</code></td>
<td>&lt;!-U022E7 /gnsim N: greater, not similar --&gt;</td>
</tr>
<tr>
<td><code>&amp;amp;#10889;</code></td>
<td>&lt;!-U02A89 /lnapprox N: less, not approximate --&gt;</td>
</tr>
<tr>
<td><code>&amp;amp;#8808;</code></td>
<td>&lt;!-U02268 /lneq N: less, not equals --&gt;</td>
</tr>
<tr>
<td><code>&amp;amp;#8808;</code></td>
<td>&lt;!-U02268 /lneqq N: less, not double equals --&gt;</td>
</tr>
<tr>
<td><code>&amp;amp;#8934;</code></td>
<td>&lt;!-U022E6 /lnsim N: less, not similar --&gt;</td>
</tr>
<tr>
<td><code>&amp;amp;#8777;</code></td>
<td>&lt;!-U02249 /napproxeq N: not approximate --&gt;</td>
</tr>
<tr>
<td><code>&amp;amp;#8775;</code></td>
<td>&lt;!-U02247 /ncong N: not congruent with --&gt;</td>
</tr>
</tbody>
</table>
**Root Element**

Every XML document has one element that contains all other elements of the document. The root element is also called the document element.

**Tags**

Tags are text structures that mark the beginning and end of elements within the XML document. Tags are markup characters.

**Child Element**

Child element is an element contained within another element. The element containing other elements is known as the parent element.

```xml
<sect1>
  <title>Energy-giving foods.</title>
  <entry align="left" valign="top">
    <para>They give us heat and energy to work and play. They also keep our skin and hair healthy. <emphasis role="bold">Carbohydrates</emphasis> and are energy- giving nutrients. x &#8808; 1200</para>
  </entry>
</sect1>
```

Thus we see that any code can be child element or parent element both. If it containing other tag then those tags will be treated it’s child element.

**Attribute**

An attribute is a property of an element. It is an additional information about a piece of data (element). Often attributes are used to pass information about the element and hence can be said to provide metadata for the element.

An attributes is a value indicator (=) and the attribute value is specified within the tag (i.e. `<H3 align="center">`). Attribute in XML is a name="value" pair that can be placed in the start tag of an element. For XML, all values must be quoted with single or double quotes.

**Content**

Content is all data between the start tag and end tag of an element. Content may be made up of markup characters and character data.

**Unicode**

is a standard for representing characters from languages around the world. Generally Entity file contains unicode characters.

**Valid**

An XML document is valid if it conforms to the vocabulary specified in a DTD or schema. In other words, an XML document with an associated document type declaration that follows all the rules of that declaration is valid.

**Well Formed**

A well-formed XML document follows all the rules of the XML specification. But it is not necessarily valid according to an associated document type declaration. A well-formed XML document does not necessarily include a DTD.
### XML Coding को best input text source file माना जाता है क्योंकि XML coded data different platform पर different packages/ software में बांट-बांट change नहीं होता है। क्योंकि वह पूरी तरह से text base होता है कोई भी character, इसमें manually set नहीं किया जाता और कोई भी client बांट-बांट के ही source data को रीकॉपर करना पड़ता। क्योंकि उसी data को multi-purpose use करना पड़ता है।

1. **XML File** में data की coding/tagging की जाती है। जो... से start और... तो close रही है।

   - **a.** XML में जो tagging की जाती है, वह tagging DTD file में well formed और serial wise define होती है। ध्यान रखना याद रहे कि XML में उन्हीं tagging का use करना चाहिएं जो DTD File में define कर सब्स कर सकता है। इससे उसमें error नहीं होगी।
   - **b.** Simple Formatting e.g.: bold, italic, ctr, left, and Callout... के लिए Attributes की coding करनी होती है। जैसे:

     ```xml
     <para>Food is divided into three categories: energy- giving, body-building and protective.</para>
     ```

2. **DTD File** में उस XML coded file को well formed checked किया जाता है।

3. **XSL File** के जैसे उनकी designing/formating की जाती है।

4. **Entity** के जैसे उनके special character की coding की जाती है। ये Internal Entity या External Entity (Separated File) भी हैं।

### मान रहां क्या material है?

<table>
<thead>
<tr>
<th>From XML Person</th>
<th>From Setup Person</th>
</tr>
</thead>
<tbody>
<tr>
<td>XML Coded File</td>
<td>DTD File</td>
</tr>
<tr>
<td>XSL File</td>
<td>Entity File</td>
</tr>
<tr>
<td>DTD File</td>
<td>Font</td>
</tr>
<tr>
<td>DTD File</td>
<td>Template</td>
</tr>
<tr>
<td>Sample File</td>
<td></td>
</tr>
</tbody>
</table>

यानि यह निश्चित निर्देशित Material जानने का भी मान रहा पास आ जा उसका अर्थ है और एम के पास at least basic जानकारी ताकि है जिससे उसकी कोई भी कोई अब तक अब हम समझते हैं कि InDesign CS2 किस प्रकार XML का support करता है।

### Getting Started XML with InDesign CS2

मान लीजिए आप संक्षेप में से coding करने है तो आप क्या करते होंगे आपका ज्ञान होगा paragraph style, character style, formatting style, special character fonts... जैसा की coding करते हैं फिर उस file को InDesign में place कर लेंगे हैं। अगर कोई style coding में गलत वर्णन नहीं हो तो उसे InDesign में ठीक लगा देंगे।

किसी भी स्थिति में, यदि coding का process भी होगा है तो coding person according to the template styling करके देंगे हैं और जब हम coded file को template में place किया जाता है तो अपने आप ही सारे style लगा जाते हैं। अतः पृष्ठ setting करनी होती है जैसे floating element like tables and figure जैसी नक़्कियों से set करती होती है।

यहाँ ये बांट ध्यान देंगे याद रहे कि normal coding person word file में जो styles की coding करते हैं वो उसी की जाती है। यानि job to job style naming change होती है।

अब हम यहाँ सा process change करते हैं और ये करते हैं फिर एक coding person आपको आपकी template के हिसाब से नहीं बल्कि अपने Fix International Standard के हिसाब से coding करके देंगे हैं। इसी से पता आपने आपकी template में कौन-कौन से style कराये हैं उसके तांत्रिक Standardisation XML Coding की और File आपका पुकार देंगे हैं।

यानि अब आपके पास XML Coded File आ जुकी है। Now you will have to import the text into your XML file. पर यहाँ ये बांट ध्यान देंगे याद रहें कि आप इस XML Coded File को किस प्रकार से अपनी InDesign Template में Place करवायें।

**Step 1:** Open the template after opening the fonts

बजी आप template open करके structure pane open करने हो तो जीवा default “Root” element display हो रहा होता है। अब आपको निम्नलिखित step लेंगे यादः

**Step 2:** “Load DTD...”

जैसे ही आप job related dtd import करेंगे “Root” के उपर dtd display हो जाएगी।
Step 3: “Import XML...” Coded File

XML Coded File import करने ही structure pane में XML style sheet पर add करे जाएगी और Root के अन्तर सारे element display हो जाएगी।

Step 4: Import the XML File into the layout

Importing XML File

पहली बार तो ये वह XML Coded File साधारण Coded File की ओर (File → Place) get ही करना होगा। इसे दो तौर पर Place करना जा सकता है।

1. File → Import XML: Simply Import the XML File
2. View → Structure → Show Structure: Then side में जो Structure Panel आया है उसके Right side में जो symbol (๐) दिख रहा है उस पर click करने अपने “Import XML... का option निकालें। उसमें Coded file को import किया जा सकता हैं।

Now you can either manually layout XML content, or automate its layout by importing it into a document that contains placeholder frames.

When you import an XML file, InDesign initially places it into the Structure Pane. If you’ve created placeholder frames (before importing the XML Coded File), InDesign can also import the content into the frames for you.

Manual Layout

The most common method for importing XML into InDesign is to drag the unplaced content from the Structure pane into frames in your document. This approach works well if you don’t know the precise sequence of elements in the imported XML file, or if you get content from multiple sources.

Automatic Layout

If you know the order of the elements in the XML file you plan to import, you can create placeholder frames for the XML content. When you import the XML file, InDesign merges the content into the placeholder frames automatically.

Figure 8.1 Manual Importing the XML Coded File.

जैसा वह आपको फालने कश्वा गया था वह XML Coding person आपकी आपकी template के अन्तर में नहीं बॉलिंग अपने Fix International Standard के नियम से coding करने देता है। उसे नहीं पता आपने अपनी template में कण-कण में style करने हैं उससे नो मास Standardisation XML Coding की और File आपकी पक्की देता है। अब आप file का place कर पक्की हो लेकिन अब आपकी पता करता है क्या बहुत में tag name आपकी template में क्या गया style से match नहीं करता।

आपके लायक अब दो तारीख हैं कि यह तो आप हर paragraph पर एक-एक करके manually सारी style लगाए या mapping कर लें। अब सक्षम उठता है ये mapping तो नहीं करा है।
What is Mapping

“Mapping is a process in which you can replace the coded file’s tag into InDesing style”.

See the below image: (Window → Tag → Map Tag to Styles)

Mapping is a process where you can replace the coded file’s tag into InDesign style. The image on the left side shows the original XML coding, while the right side shows the resulting styled content. InDesign supports mapping by allowing you to associate XML tags with specific style attributes. When you use the “Map Tag to Styles” feature, you can set up a mapping that automatically applies the appropriate InDesign styles to the XML tags. This makes it easier to manage complex documents and ensures consistency in styling and formatting.

**Tables Attributes**

Table attributes are used to specify how table rows and columns are formatted and aligned. They help maintain consistency in the layout and appearance of tabular data. The table below lists some common table attributes:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>table</td>
<td>table</td>
<td>Specifies a table-type element. A value of “table” indicates the container TABLE element; a value of “cell” indicates a cell element.</td>
</tr>
<tr>
<td>trows</td>
<td>Numeric</td>
<td>Specifies the number of ROWS in the table.</td>
</tr>
<tr>
<td>tcols</td>
<td>Numeric</td>
<td>Specifies the number of COLUMNS in the table.</td>
</tr>
<tr>
<td>theader</td>
<td>Empty</td>
<td>If present, the theader attribute indicates that the current cell is part of a TABLE HEADER row.</td>
</tr>
<tr>
<td>crows</td>
<td>Numeric</td>
<td>Specifies how many ROWS the CURRENT CELL SPANS. The default is 1.</td>
</tr>
<tr>
<td>ccols</td>
<td>Numeric</td>
<td>Specifies how many COLUMNS the CURRENT CELL SPANS. The default is 1.</td>
</tr>
<tr>
<td>ccolwidth</td>
<td>Numeric</td>
<td>Specifies the WIDTH, in points, of the CURRENT CELL.</td>
</tr>
<tr>
<td>tfooter</td>
<td>Empty</td>
<td>If present, the tfooter attribute indicates that the current cell is part of a TABLE FOOTER row.</td>
</tr>
</tbody>
</table>
Here is an example of a table.

<table>
<thead>
<tr>
<th>Table Header 1</th>
<th>Table Header 2</th>
<th>Table Header 3</th>
<th>Table Header 4</th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>B</td>
<td>C</td>
<td>D</td>
</tr>
<tr>
<td>E straddles two columns</td>
<td>F</td>
<td>G</td>
<td></td>
</tr>
<tr>
<td>H</td>
<td>I</td>
<td>J straddles two rows</td>
<td>K</td>
</tr>
<tr>
<td>L</td>
<td>M</td>
<td></td>
<td>N</td>
</tr>
</tbody>
</table>

The XML code for the table is shown below:

```xml
<Table xmlns:aid="http://ns.adobe.com/AdobeInDesign/4.0/" aid:table="table" aid:trows="6" aid:tcols="4">
  <Cell aid:table="cell" aid:theader="" aid:crows="1" aid:ccols="1">Table header 1</Cell>
  <Cell aid:table="cell" aid:theader="" aid:crows="1" aid:ccols="1">Table header 2</Cell>
  <Cell aid:table="cell" aid:theader="" aid:crows="1" aid:ccols="1" aid:ccolwidth="130">Table header 3</Cell>
  <Cell aid:table="cell" aid:theader="" aid:crows="1" aid:ccols="1" aid:ccolwidth="130">Table header 4</Cell>
  <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:crowspan="2">A</Cell>
  <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:crowspan="2">E straddles two columns</Cell>
  <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:crowspan="1">F</Cell>
  <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:crowspan="1">G</Cell>
  <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:crowspan="1">H</Cell>
  <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:crowspan="1">I</Cell>
  <Cell aid:table="cell" aid:crows="2" aid:ccols="1" aid:crowspan="2">J straddles two rows</Cell>
  <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:crowspan="1">K</Cell>
  <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:crowspan="1">L</Cell>
  <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:crowspan="1">M</Cell>
  <Cell aid:table="cell" aid:crows="1" aid:ccols="1" aid:crowspan="1">N</Cell>
  <Cell aid:table="cell" aid:tfooter="" aid:crows="1" aid:ccols="1" aid:crowspan="1" aid:ccolwidth="130">Table footer</Cell>
</Table>
```

The `aid:trows` and `aid:tcols` attributes specify the number of rows and columns in the table.

The empty `aid:theader` attribute indicates a heading cell. Footing cells use a similar `aid:tfooter` attribute. Regular table cells do not have an attribute to indicate what type they are.

The `aid:ccols` attribute indicates that the current cell spans the specified number of columns. The default, 1, indicates no column spanning. The `aid:crows` attribute indicates row spanning.

### Understand/Learn the other Terms of InDesign XML

InDesign lets you import and layout XML content, as well as export documents to XML. Because the hierarchy and order of elements is so important in XML files, you will use the Structure pane and Tags palette frequently when working with XML content. The Structure pane displays all the elements within the document and their hierarchy. To help you identify the elements, InDesign displays the element tag and icons that represent different types of content, such as text or graphics. In addition, it can display the first words of any text within an element, called a text snippet.

The Structure Pane lets you view, edit, and manage your XML elements. You use the Structure pane in many ways when working with XML. For example:

1. to place imported XML content into the layout, you can drag elements from the Structure pane directly to a page.
2. When you apply tags to content, you use the Structure pane to adjust the hierarchy of the elements.
3. You can add elements, attributes, comments, and processing instructions.
The Tags Palette lists tags for each element in a document. You can import, export, add, delete, and rename tags. You use the Tags palette to apply element tags to content that you plan to export to XML. You can also use it to tag frames before importing XML into them.

**Understand the Structuring Pane**

The Structure pane displays a hierarchical tree of tagged page items and imported XML content. Items that appear in the Structure pane are called elements. At a glance, the Structure pane shows which elements have been placed on the page and which have not (a blue diamond on an element icon indicates that the element is attached to a page item). You select and move elements in the Structure pane to define the sequence and hierarchy of page items in the exported XML file.

**Structure Pane Icons with It’s Name and Functions**

When a tagged page item is selected in the document layout, the corresponding item is underlined in the Structure pane. The following icons appear in the Structure pane:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Structural Element" /></td>
<td>Structural Element</td>
<td>Each document includes only one root element, which can be renamed, but cannot be moved or deleted. Other structural elements are used to organize the elements listed below.</td>
</tr>
<tr>
<td><img src="image" alt="Story Element" /></td>
<td>Story Element</td>
<td>Represents tagged stories (one or more linked frames).</td>
</tr>
<tr>
<td><img src="image" alt="Text Element" /></td>
<td>Text Element</td>
<td>Represents XML-tagged text within a frame.</td>
</tr>
<tr>
<td><img src="image" alt="Graphic Element" /></td>
<td>Graphic Element</td>
<td>Represents a tagged frame that includes a placed image. Each graphic element includes an “href” attribute that defines the path or URL to the linked file.</td>
</tr>
<tr>
<td><img src="image" alt="Unplaced Text Element" /></td>
<td>Unplaced Text Element</td>
<td>Unplaced text element not yet associated with a page item in the document layout.</td>
</tr>
<tr>
<td><img src="image" alt="Unplaced Graphic Element" /></td>
<td>Unplaced Graphic Element</td>
<td>Unplaced graphic element not yet associated with a page item in the document layout.</td>
</tr>
<tr>
<td><img src="image" alt="Table Element" /></td>
<td>Table Element</td>
<td>Represents a table.</td>
</tr>
<tr>
<td><img src="image" alt="Header Cell Element" /></td>
<td>Header Cell Element</td>
<td>Represents a cell in the header row of a table.</td>
</tr>
<tr>
<td><img src="image" alt="Body Cell Element" /></td>
<td>Body Cell Element</td>
<td>Represents a cell within the body of a table.</td>
</tr>
<tr>
<td><img src="image" alt="Footer Cell Element" /></td>
<td>Footer Cell Element</td>
<td>Represents a cell in the footer row of a table.</td>
</tr>
<tr>
<td><img src="image" alt="Empty Element" /></td>
<td>Empty Element</td>
<td>An empty frame is associated with this element.</td>
</tr>
<tr>
<td><img src="image" alt="Attribute" /></td>
<td>Attribute</td>
<td>Includes metadata, such as keywords or location of a linked image (HREF attribute). Attributes are meaningful in XML but do not appear in the InDesign document itself.</td>
</tr>
<tr>
<td><img src="image" alt="Comment" /></td>
<td>Comment</td>
<td>Includes comments that appear in the XML file, but not the InDesign document.</td>
</tr>
<tr>
<td><img src="image" alt="Processing Instruction" /></td>
<td>Processing Instruction</td>
<td>Includes an instruction that triggers an action in applications that can read processing instructions.</td>
</tr>
<tr>
<td><img src="image" alt="Doctype Element" /></td>
<td>Doctype Element</td>
<td>Tells InDesign which DTD file to use when validating the XML file.</td>
</tr>
</tbody>
</table>
To Use The Structure Pane

- To view the Structure pane, choose View → Structure → Show Structure.
- To expand or collapse an element, click the triangle next to the element you want to expand or collapse.
- To expand or contract an element as well as all elements contained within it, hold down Command Key while clicking the triangle next to the element.
- To show or hide text snippets, choose Show Text Snippets or Hide Text Snippets from the Structure pane menu. Showing or hiding text snippets sets the default for any new document you create.
- To resize the Structure pane, drag the splitter button (at the bottom of the document window) left or right.
- To open the Structure pane to the last saved width, or to close the Structure pane if it’s open, click the splitter button at the bottom of the document window.

To Rearrange Elements

You can rearrange the order of elements in the Structure pane. The root element must remain at the top of the structure. Only the DTD (appearing as a DOCTYPE element), comments, or processing instructions can appear above the root element. You cannot move or delete the root element or the DOCTYPE element. In addition, you cannot drag table cell elements or drop elements into a table element.

Changing the hierarchy affects the structure of exported XML files. If you move a text element to make it the child of an element elsewhere in the structure, the text in the layout also moves.

In the Structure pane, you can do the following:

- To move an element, drag it to a new location within the structure tree. A line appears when you drag to indicate where you are inserting the element. The width of the line marks the level within the hierarchy.
- To make an element a child of another element, either position it over the parent element to highlight it or place it amongst the parent’s other child elements, and then release the mouse button.
- To move an element out a level in the hierarchy, drag it just above another parent element and move to the left slightly until the line indicating its placement spans the width of the parent element.
- To copy or cut an element, select the element or elements in the Structure pane, and then choose Edit → Copy or Edit → Cut. Select the element directly above where you want to insert the element, and choose Edit → Paste.

Note: When you cut an element, the element and contents are cut to the clipboard, but the frame remains intact.

Viewing XML tags

To help you manage XML tags in an InDesign file, you can set up the file to show tags. In the main document window, tags appear as colored brackets. In the Story Editor, the entire tag name appears. To display XML tags, choose View → Structure → Show Tag Markers.
To Show or Hide Tagged Frames or Tag Markers

You can display tagged frames in color or display colored brackets around tagged text. The tag color determines the color of the frame or bracket.

- To display tagged frames in color, choose View → Structure → Show Tagged Frames.
- To hide the color-coding of tagged frames, choose View → Structure → Hide Tagged Frames.
- To display color brackets around tagged text, choose View → Structure → Show Tag Markers.
- To hide color brackets around tagged text, choose View → Structure → Hide Tag Markers.

To minimize the risk of accidentally deleting a tag marker, edit tagged text in Story Editor, where tag markers are more visible.

Note: If you choose Type → Show Hidden Characters, markers for returns, index entries, and hyperlinks will appear.

To Validate XML Structure

When you validate the XML in a document, InDesign compares the structure, element tag names, and attributes against the DTD you loaded. InDesign alerts you if the XML deviates from the DTD, and suggest the ways to fix the XML to match the DTD requirements. You can fix errors one at a time or view all errors at once in a separate window.

A. Loaded DTD
B. Error or invalidating condition
C. Description of error with suggested fix
D. Error count
E. Validate button
F. View all errors at once in a separate window
Thanks

Written and Composed by

Deepak Aggarwal
Trainer

K-123, Street No.-11, Sombazar Road,
Rajapuri, Uttam Nagar, N.D.- 59
(Opp Dwarka Sec-4)
Phone: +91 9899123045
e-Mail: info@biotics.in
website: www.biotics.in